aboutsummaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGravatar Sebastian Harl <sh@teamix.net> 2011-04-07 17:24:23 +0200
committerGravatar Sebastian Harl <sh@teamix.net> 2012-06-06 14:10:55 +0200
commitf9a942d2a11e70ee68d5ea2c9aa762bff004bf43 (patch)
tree31ce3a05d1bdc715bf7a0230280d1d16940212ad /plugins/Makefile.am
parent804e7d878cad5c76474fd2abf2130ff446dbda5d (diff)
downloadmonitoring-plugins-f9a942d2a11e70ee68d5ea2c9aa762bff004bf43.tar.gz
Initial version of the 'check_dbi' plugin.
This plugin connects to an SQL database using libdbi, thus supporting all database backends supported by libdbi. It will then issue the specified SQL query and check the result (the numeric value of the first column of the first row to be precise) against the specified warning/critical ranges. The performance data includes the connection time (µs-resolution as provided by gettimeofday()) and the query result.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 36a28b0b..4781e0fc 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -37,7 +37,7 @@ check_tcp_programs = check_ftp check_imap check_nntp check_pop \
EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \
check_swap check_fping check_ldap check_game check_dig \
check_nagios check_by_ssh check_dns check_nt check_ide_smart \
- check_procs check_mysql_query check_apt
+ check_procs check_mysql_query check_apt check_dbi
EXTRA_DIST = t tests utils.c netutils.c sslutils.c popen.c utils.h netutils.h \
popen.h common.h runcmd.c runcmd.h
@@ -64,6 +64,7 @@ test-debug:
check_apt_LDADD = $(BASEOBJS) runcmd.o
check_cluster_LDADD = $(BASEOBJS)
+check_dbi_LDADD = $(NETLIBS) $(DBILIBS)
check_dig_LDADD = $(NETLIBS) runcmd.o
check_disk_LDADD = $(BASEOBJS) popen.o
check_dns_LDADD = $(NETLIBS) runcmd.o
@@ -109,6 +110,7 @@ urlize_LDADD = $(BASEOBJS) popen.o
check_apt_DEPENDENCIES = check_apt.c $(BASEOBJS) runcmd.o $(DEPLIBS)
check_cluster_DEPENDENCIES = check_cluster.c $(BASEOBJS) $(DEPLIBS)
+check_dbi_DEPENDENCIES = check_dbi.c $(NETOBJS) $(DEPLIBS)
check_dig_DEPENDENCIES = check_dig.c $(NETOBJS) runcmd.o $(DEPLIBS)
check_disk_DEPENDENCIES = check_disk.c $(BASEOBJS) popen.o $(DEPLIBS)
check_dns_DEPENDENCIES = check_dns.c $(NETOBJS) runcmd.o $(DEPLIBS)