aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 02514aa0..20d55907 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,21 +1,25 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = lib plugins plugins-scripts
+SUBDIRS = intl lib plugins plugins-scripts po
-EXTRA_DIST = CODING FAQ LEGAL REQUIREMENTS SUPPORT \
+EXTRA_DIST = config.rpath \
+ ABOUT-NLS CODING FAQ LEGAL REQUIREMENTS SUPPORT \
Helper.pm contrib pkg nagios-plugins.spec.in
ACLOCAL_AMFLAGS = -I lib
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\"
+
dist-hook:
- sed "s/%%{VER}/${VER}/;s/%%{REL}/${REL}/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec
+ sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec
test:
cd plugins; $(MAKE) test
cd plugins-scripts; $(MAKE) test
nagios-plugins.spec: nagios-plugins.spec.in
- sed "s/%%{VER}/${VER}/;s/%%{REL}/${REL}/;" $? > $@
+ sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $? > $@
# Solaris pkgmk
BUILDDIR = build-solaris