aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dc166546..98542b94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
SUBDIRS = gl tap lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@
EXTRA_DIST = config.rpath \
- ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS CODING FAQ LEGAL NEWS \
+ ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ LEGAL NEWS \
NP-VERSION-GEN REQUIREMENTS SUPPORT THANKS \
NPTest.pm pkg nagios-plugins.spec \
config_test/Makefile config_test/run_tests config_test/child_test.c \
@@ -15,6 +15,13 @@ ACLOCAL_AMFLAGS = -I gl/m4 -I m4
localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\"
+#
+# The ChangeLog file is auto-generated from the Git history. We let it depend
+# on NP-VERSION-GEN, as we bump our version number in that file.
+#
+ChangeLog: NP-VERSION-GEN
+ $(top_srcdir)/tools/generate-change-log > $@
+
dist-hook:
$(MAKE) THANKS
echo ${VERSION} >$(distdir)/release