aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index a6261c63..5c067b4a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,23 +1,18 @@
dnl Process this file with autoconf to produce a configure script.
AC_REVISION ($Revision$)
AC_PREREQ(2.50)
-AC_INIT(Helper.pm)
-VER=1.3.99
-REL=1
-AC_SUBST(VER)
-AC_SUBST(REL)
-PACKAGE_VERSION="${VER}"
-AC_SUBST(PACKAGE_VERSION)
-PACKAGE_RELEASE="${REL}"
-AC_SUBST(PACKAGE_RELEASE)
-AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION})
+AC_INIT(nagios-plugins,1.3.99)
+AC_CONFIG_SRCDIR(Helper.pm)
+AM_INIT_AUTOMAKE
AM_CONFIG_HEADER(plugins/config.h)
AC_CANONICAL_HOST
+RELEASE=1
+AC_SUBST(RELEASE)
+
AC_PREFIX_DEFAULT(/usr/local/nagios)
dnl Figure out how to invoke "install" and what install options to use.
-
AC_PROG_INSTALL
AC_SUBST(INSTALL)
@@ -1394,9 +1389,10 @@ AC_SUBST(EXTRAS)
AC_SUBST(EXTRA_NETOBJS)
AC_SUBST(DEPLIBS)
-AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version])
+GETTEXT_VERSION=0.11.4
+AM_GNU_GETTEXT
-AC_OUTPUT(Makefile lib/Makefile plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl pkg/solaris/pkginfo)
+AC_OUTPUT(Makefile lib/Makefile plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl pkg/solaris/pkginfo intl/Makefile po/Makefile.in )
ACX_FEATURE([with],[cgiurl])
ACX_FEATURE([with],[nagios-user])