aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9a8991e1..0f40bf1f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,7 @@
## Process this file with automake to produce Makefile.in
+SUBDIRS = tests
+
noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
# Will auto pick up fsusage.c mountlist.c
@@ -39,13 +41,16 @@ other_coreutils_files = \
libcoreutils_a_LIBADD = $(LIBOBJS)
libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
-libnagiosplug_a_SOURCES = snprintf.c
+libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c
-INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
+INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
print_coreutil_files:
@echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
+test:
+ cd tests && make test
+
# Below are from coreutil's lib/Makefile.am
BUILT_SOURCES = $(STDBOOL_H)
EXTRA_DIST += stdbool_.h