aboutsummaryrefslogtreecommitdiff
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index 2f464002..0ddc8abf 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -39,5 +39,8 @@ test_base64_LDFLAGS = -L/usr/local/lib -ltap
test_base64_LDADD = ../base64.o
test: ${noinst_PROGRAMS}
+ perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
+
+test-debug: ${noinst_PROGRAMS}
perl -MTest::Harness -e '$$Test::Harness::verbose=1; $$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)