aboutsummaryrefslogtreecommitdiff
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
index 01fca20d..c9e3e40e 100644
--- a/plugins-scripts/Makefile.am
+++ b/plugins-scripts/Makefile.am
@@ -1,5 +1,11 @@
## Process this file with automake to produce Makefile.in
+NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
+ @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
+-include NP-VERSION-FILE
+
+export NP_VERSION:= $(NP_VERSION)
+
SUFFIXES = .pl .sh
VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t
@@ -18,6 +24,8 @@ TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
TESTS = @SCRIPT_TEST@
+all-local: NP-VERSION-FILE
+
test:
perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t # utils.t is excluded from above, so manually ask to test
@@ -35,3 +43,8 @@ CLEANFILES=$(libexec_SCRIPTS)
.sh :
$(AWK) -f ./subst $< > $@
chmod +x $@
+
+clean-local:
+ rm -f NP-VERSION-FILE
+
+.PHONY: .FORCE-NP-VERSION-FILE